import Foundation
let pattern = #"(?:azienda|societa)'\s+(.*?)\s+ha"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Vista la domanda presentata in data 26 febbraio 2021 con la quale
la societa' Orpha-Devel Handels Und Vertriebs GMBH ha chiesto la
riclassificazione dalla classe C(nn) alla classe H del medicinale
«Tresuvi» (treprostinil) relativamente alle confezioni aventi A.I.C.
n. 049207032, 049207044, 049207018 e 049207020;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)