# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:azienda|societa)'\s+(.*?)\s+ha"
test_str = ("Vista la domanda presentata in data 26 febbraio 2021 con la quale\n"
"la societa' Orpha-Devel Handels Und Vertriebs GMBH ha chiesto la\n"
"riclassificazione dalla classe C(nn) alla classe H del medicinale\n"
"«Tresuvi» (treprostinil) relativamente alle confezioni aventi A.I.C.\n"
"n. 049207032, 049207044, 049207018 e 049207020;")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.