package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:azienda|societa)'\s+(.*?)\s+ha`)
var str = `Vista la domanda presentata in data 26 febbraio 2021 con la quale
la societa' Orpha-Devel Handels Und Vertriebs GMBH ha chiesto la
riclassificazione dalla classe C(nn) alla classe H del medicinale
«Tresuvi» (treprostinil) relativamente alle confezioni aventi A.I.C.
n. 049207032, 049207044, 049207018 e 049207020;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}