use strict;
my $str = 'Vista la domanda presentata in data 26 febbraio 2021 con la quale
la societa\' Orpha-Devel Handels Und Vertriebs GMBH ha chiesto la
riclassificazione dalla classe C(nn) alla classe H del medicinale
«Tresuvi» (treprostinil) relativamente alle confezioni aventi A.I.C.
n. 049207032, 049207044, 049207018 e 049207020;';
my $regex = qr/(?:azienda|societa)'\s+(.*?)\s+ha/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}