# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<(PUB_DATE|DATE_COLLECT_100)>([[:digit:]]{4}-[[:digit:]]{2}-[[:digit:]]{2}T[[:digit:]]{2}:[[:digit:]]{2}:[[:digit:]]{2})Z<\\/\1>/<$1>$2.001Z<\/$1>/gm;t' <<< "<PUB_DATE>2021-06-25T21:17:51Z</PUB_DATE>
<DATE_COLLECT_100>2021-06-25T21:17:51Z</DATE_COLLECT_100>"