import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(PUB_DATE|DATE_COLLECT_100)>([[:digit:]]{4}-[[:digit:]]{2}-[[:digit:]]{2}T[[:digit:]]{2}:[[:digit:]]{2}:[[:digit:]]{2})Z<\\/\\1>";
final String string = "<PUB_DATE>2021-06-25T21:17:51Z</PUB_DATE>\n"
+ "<DATE_COLLECT_100>2021-06-25T21:17:51Z</DATE_COLLECT_100>";
final String subst = "<$1>$2.001Z</$1>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}