#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<(PUB_DATE|DATE_COLLECT_100)>([[:digit:]]{4}-[[:digit:]]{2}-[[:digit:]]{2}T[[:digit:]]{2}:[[:digit:]]{2}:[[:digit:]]{2})Z<\/\1>"
Local $sString = "<PUB_DATE>2021-06-25T21:17:51Z</PUB_DATE>" & @CRLF & _
"<DATE_COLLECT_100>2021-06-25T21:17:51Z</DATE_COLLECT_100>"
Local $sSubst = "<$1>$2.001Z</$1>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)