use strict;
my $str = '<PUB_DATE>2021-06-25T21:17:51Z</PUB_DATE>
<DATE_COLLECT_100>2021-06-25T21:17:51Z</DATE_COLLECT_100>';
my $regex = qr/<(PUB_DATE|DATE_COLLECT_100)>([[:digit:]]{4}-[[:digit:]]{2}-[[:digit:]]{2}T[[:digit:]]{2}:[[:digit:]]{2}:[[:digit:]]{2})Z<\/\1>/mp;
my $subst = '<$1>$2.001Z</$1>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";