const regex = /<(PUB_DATE|DATE_COLLECT_100)>([[:digit:]]{4}-[[:digit:]]{2}-[[:digit:]]{2}T[[:digit:]]{2}:[[:digit:]]{2}:[[:digit:]]{2})Z<\/\1>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(PUB_DATE|DATE_COLLECT_100)>([[:digit:]]{4}-[[:digit:]]{2}-[[:digit:]]{2}T[[:digit:]]{2}:[[:digit:]]{2}:[[:digit:]]{2})Z<\\\/\\1>', 'gm')
const str = `<PUB_DATE>2021-06-25T21:17:51Z</PUB_DATE>
<DATE_COLLECT_100>2021-06-25T21:17:51Z</DATE_COLLECT_100>`;
const subst = `<$1>$2.001Z</$1>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);