import re
regex = re.compile(r"<(PUB_DATE|DATE_COLLECT_100)>([[:digit:]]{4}-[[:digit:]]{2}-[[:digit:]]{2}T[[:digit:]]{2}:[[:digit:]]{2}:[[:digit:]]{2})Z<\/\1>", flags=re.MULTILINE)
test_str = ("<PUB_DATE>2021-06-25T21:17:51Z</PUB_DATE>\n"
"<DATE_COLLECT_100>2021-06-25T21:17:51Z</DATE_COLLECT_100>")
subst = "<$1>$2.001Z</$1>"
result = regex.sub(subst, test_str)
if result:
print(result)