import Foundation
let pattern = #"<(PUB_DATE|DATE_COLLECT_100)>([[:digit:]]{4}-[[:digit:]]{2}-[[:digit:]]{2}T[[:digit:]]{2}:[[:digit:]]{2}:[[:digit:]]{2})Z<\/\1>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<PUB_DATE>2021-06-25T21:17:51Z</PUB_DATE>
<DATE_COLLECT_100>2021-06-25T21:17:51Z</DATE_COLLECT_100>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<$1>$2.001Z</$1>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)