# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\s{4}\(bingo\).*\s//gm;t' <<< "(
(text
(bingo) <-- keep this (level=3)
text)
(text)
(bingo) <-- kick this (level=2)
(text)
)"