const regex = /^\s{4}\(bingo\).*\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s{4}\\(bingo\\).*\\s', 'gm')
const str = `(
(text
(bingo) <-- keep this (level=3)
text)
(text)
(bingo) <-- kick this (level=2)
(text)
)`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);