import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s{4}\\(bingo\\).*\\s";
final String string = "(\n"
+ " (text \n"
+ " (bingo) <-- keep this (level=3)\n"
+ " text)\n"
+ " (text)\n"
+ " (bingo) <-- kick this (level=2)\n"
+ " (text)\n"
+ ")";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}