import re
regex = re.compile(r"^\s{4}\(bingo\).*\s", flags=re.MULTILINE)
test_str = ("(\n"
" (text \n"
" (bingo) <-- keep this (level=3)\n"
" text)\n"
" (text)\n"
" (bingo) <-- kick this (level=2)\n"
" (text)\n"
")")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)