re = /^\s{4}\(bingo\).*\s/m
str = '(
(text
(bingo) <-- keep this (level=3)
text)
(text)
(bingo) <-- kick this (level=2)
(text)
)'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result