package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s{4}\(bingo\).*\s`)
var str = `(
(text
(bingo) <-- keep this (level=3)
text)
(text)
(bingo) <-- kick this (level=2)
(text)
)`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}