package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?://([^/]+)\S*`)
var str = `https://www.youtube.com/watch?=whatever"`
var substitution = "(link from $1)"
fmt.Println(re.ReplaceAllString(str, substitution))
}