import Foundation
let pattern = #"https?://([^/]+)\S*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"https://www.youtube.com/watch?=whatever""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"(link from $1)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)