$re = '~https?://([^/]+)\S*~m';
$str = 'https://www.youtube.com/watch?=whatever"';
$subst = "(link from $1)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;