use strict;
my $str = 'https://www.youtube.com/watch?=whatever"';
my $regex = qr~https?://([^/]+)\S*~mp;
my $subst = '(link from $1)';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";