#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((http|https)://)?www.safmarine.com(/([a-zA-Z]{2})?(-[a-zA-Z]{2})?)?/glossary(/*)$" & @CRLF & _
""
Local $sString = "http://www.safmarine.com/glossary" & @CRLF & _
"http://www.safmarine.com/glossary/" & @CRLF & _
"https://www.safmarine.com/en/glossary/" & @CRLF & _
"https://www.safmarine.com/en-gb/glossary/" & @CRLF & _
"https://www.safmarine.com/glossary/" & @CRLF & _
"https://www.safmarine.com/glossary/B" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")