$re = '/^((http|https)://)?www.safmarine.com(/([a-zA-Z]{2})?(-[a-zA-Z]{2})?)?/glossary(/*)$
/m';
$str = 'http://www.safmarine.com/glossary
http://www.safmarine.com/glossary/
https://www.safmarine.com/en/glossary/
https://www.safmarine.com/en-gb/glossary/
https://www.safmarine.com/glossary/
https://www.safmarine.com/glossary/B
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);