const regex = new RegExp('^((http|https)://)?www.safmarine.com(/([a-zA-Z]{2})?(-[a-zA-Z]{2})?)?/glossary(/*)$
', 'gm')
const str = `http://www.safmarine.com/glossary
http://www.safmarine.com/glossary/
https://www.safmarine.com/en/glossary/
https://www.safmarine.com/en-gb/glossary/
https://www.safmarine.com/glossary/
https://www.safmarine.com/glossary/B
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}