re = /^((http|https):\/\/)?www.safmarine.com(\/([a-zA-Z]{2})?(-[a-zA-Z]{2})?)?\/glossary(\/*)$
/m
str = 'http://www.safmarine.com/glossary
http://www.safmarine.com/glossary/
https://www.safmarine.com/en/glossary/
https://www.safmarine.com/en-gb/glossary/
https://www.safmarine.com/glossary/
https://www.safmarine.com/glossary/B
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end