import re
regex = re.compile((r"^((http|https)://)?www.safmarine.com(/([a-zA-Z]{2})?(-[a-zA-Z]{2})?)?/glossary(/*)$\n"), flags=re.MULTILINE)
test_str = ("http://www.safmarine.com/glossary\n"
"http://www.safmarine.com/glossary/\n"
"https://www.safmarine.com/en/glossary/\n"
"https://www.safmarine.com/en-gb/glossary/\n"
"https://www.safmarine.com/glossary/\n"
"https://www.safmarine.com/glossary/B\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")