import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((http|https)://)?www.safmarine.com(/([a-zA-Z]{2})?(-[a-zA-Z]{2})?)?/glossary(/*)$\n";
final String string = "http://www.safmarine.com/glossary\n"
+ "http://www.safmarine.com/glossary/\n"
+ "https://www.safmarine.com/en/glossary/\n"
+ "https://www.safmarine.com/en-gb/glossary/\n"
+ "https://www.safmarine.com/glossary/\n"
+ "https://www.safmarine.com/glossary/B\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}