import Foundation
let pattern = #"""
^((http|https)://)?www.safmarine.com(/([a-zA-Z]{2})?(-[a-zA-Z]{2})?)?/glossary(/*)$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://www.safmarine.com/glossary
http://www.safmarine.com/glossary/
https://www.safmarine.com/en/glossary/
https://www.safmarine.com/en-gb/glossary/
https://www.safmarine.com/glossary/
https://www.safmarine.com/glossary/B
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)