package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((http|https)://)?www.safmarine.com(/([a-zA-Z]{2})?(-[a-zA-Z]{2})?)?/glossary(/*)$
`)
var str = `http://www.safmarine.com/glossary
http://www.safmarine.com/glossary/
https://www.safmarine.com/en/glossary/
https://www.safmarine.com/en-gb/glossary/
https://www.safmarine.com/glossary/
https://www.safmarine.com/glossary/B
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}