#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(sd[a-z]{1,2})|(nvme[0-9]{1,2})|(mmcblk[0-9]{1,2})"
Local $sString = "mmcblk0p1" & @CRLF & _
"mmcblk0p2" & @CRLF & _
"mmcblk1p1" & @CRLF & _
"mmcblk0p2" & @CRLF & _
"sda" & @CRLF & _
"sda1" & @CRLF & _
"sdb" & @CRLF & _
"sdb2" & @CRLF & _
"sdaa" & @CRLF & _
"sdbb" & @CRLF & _
"sdcc" & @CRLF & _
"nvme0" & @CRLF & _
"nvme1" & @CRLF & _
"nvme0p1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")