using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(sd[a-z]{1,2})|(nvme[0-9]{1,2})|(mmcblk[0-9]{1,2})";
string input = @"mmcblk0p1
mmcblk0p2
mmcblk1p1
mmcblk0p2
sda
sda1
sdb
sdb2
sdaa
sdbb
sdcc
nvme0
nvme1
nvme0p1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}