package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(sd[a-z]{1,2})|(nvme[0-9]{1,2})|(mmcblk[0-9]{1,2})`)
var str = `mmcblk0p1
mmcblk0p2
mmcblk1p1
mmcblk0p2
sda
sda1
sdb
sdb2
sdaa
sdbb
sdcc
nvme0
nvme1
nvme0p1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}