import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(sd[a-z]{1,2})|(nvme[0-9]{1,2})|(mmcblk[0-9]{1,2})";
final String string = "mmcblk0p1\n"
+ "mmcblk0p2\n"
+ "mmcblk1p1\n"
+ "mmcblk0p2\n"
+ "sda\n"
+ "sda1\n"
+ "sdb\n"
+ "sdb2\n"
+ "sdaa\n"
+ "sdbb\n"
+ "sdcc\n"
+ "nvme0\n"
+ "nvme1\n"
+ "nvme0p1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}