$re = '/(sd[a-z]{1,2})|(nvme[0-9]{1,2})|(mmcblk[0-9]{1,2})/m';
$str = 'mmcblk0p1
mmcblk0p2
mmcblk1p1
mmcblk0p2
sda
sda1
sdb
sdb2
sdaa
sdbb
sdcc
nvme0
nvme1
nvme0p1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);