use strict;
my $str = 'mmcblk0p1
mmcblk0p2
mmcblk1p1
mmcblk0p2
sda
sda1
sdb
sdb2
sdaa
sdbb
sdcc
nvme0
nvme1
nvme0p1';
my $regex = qr/(sd[a-z]{1,2})|(nvme[0-9]{1,2})|(mmcblk[0-9]{1,2})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}