import re
regex = re.compile(r"(sd[a-z]{1,2})|(nvme[0-9]{1,2})|(mmcblk[0-9]{1,2})", flags=re.MULTILINE)
test_str = ("mmcblk0p1\n"
"mmcblk0p2\n"
"mmcblk1p1\n"
"mmcblk0p2\n"
"sda\n"
"sda1\n"
"sdb\n"
"sdb2\n"
"sdaa\n"
"sdbb\n"
"sdcc\n"
"nvme0\n"
"nvme1\n"
"nvme0p1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")