// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(sd[a-z]{1,2})|(nvme[0-9]{1,2})|(mmcblk[0-9]{1,2})").unwrap();
let string = "mmcblk0p1
mmcblk0p2
mmcblk1p1
mmcblk0p2
sda
sda1
sdb
sdb2
sdaa
sdbb
sdcc
nvme0
nvme1
nvme0p1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}