#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^&[^-]+-(?<pagination>\d+)&?$"
Local $sString = "&sot-4" & @CRLF & _
"&dorer-56&" & @CRLF & _
"&sot-281&" & @CRLF & _
"&dorer-0" & @CRLF & _
"" & @CRLF & _
"sot-5" & @CRLF & _
"&dorer-" & @CRLF & _
"&sot-&" & @CRLF & _
"dorer-34&"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")