// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^&[^-]+-(?<pagination>\d+)&?$").unwrap();
let string = "&sot-4
&dorer-56&
&sot-281&
&dorer-0
sot-5
&dorer-
&sot-&
dorer-34&";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}