$re = '/^&[^-]+-(?<pagination>\d+)&?$/m';
$str = '&sot-4
&dorer-56&
&sot-281&
&dorer-0
sot-5
&dorer-
&sot-&
dorer-34&';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);