using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^&[^-]+-(?<pagination>\d+)&?$";
string input = @"&sot-4
&dorer-56&
&sot-281&
&dorer-0
sot-5
&dorer-
&sot-&
dorer-34&";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}