import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^&[^-]+-(?<pagination>\\d+)&?$";
final String string = "&sot-4\n"
+ "&dorer-56&\n"
+ "&sot-281&\n"
+ "&dorer-0\n\n"
+ "sot-5\n"
+ "&dorer-\n"
+ "&sot-&\n"
+ "dorer-34&";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}