const regex = /^&[^-]+-(?<pagination>\d+)&?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^&[^-]+-(?<pagination>\\d+)&?$', 'gm')
const str = `&sot-4
&dorer-56&
&sot-281&
&dorer-0
sot-5
&dorer-
&sot-&
dorer-34&`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}