re = /^&[^-]+-(?<pagination>\d+)&?$/m
str = '&sot-4
&dorer-56&
&sot-281&
&dorer-0
sot-5
&dorer-
&sot-&
dorer-34&'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end