import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\+|\\d)[\\d\\-\\(\\) ]{9,}\\d";
final String string = "вфыв ыфв фыв 8 900 000-00-00 вфыв ыфв фыв \n\n"
+ "вфыв ыфв фыв +7 (900) 000 00-00 вфыв ыфв фыв \n\n"
+ "вфыв ыфв фыв +7 9001112233 вфыв ыфв фыв \n\n"
+ "вфыв ыфв фыв 89001112233 вфыв ыфв фыв \n\n"
+ "вфыв ыфв фыв 8(900) 111-2233 вфыв ыфв фыв ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}