$re = '/(?:\+|\d)[\d\-\(\) ]{9,}\d/';
$str = 'вфыв ыфв фыв 8 900 000-00-00 вфыв ыфв фыв
вфыв ыфв фыв +7 (900) 000 00-00 вфыв ыфв фыв
вфыв ыфв фыв +7 9001112233 вфыв ыфв фыв
вфыв ыфв фыв 89001112233 вфыв ыфв фыв
вфыв ыфв фыв 8(900) 111-2233 вфыв ыфв фыв ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);