import re
regex = re.compile(r"(?:\+|\d)[\d\-\(\) ]{9,}\d")
test_str = ("вфыв ыфв фыв 8 900 000-00-00 вфыв ыфв фыв \n\n"
"вфыв ыфв фыв +7 (900) 000 00-00 вфыв ыфв фыв \n\n"
"вфыв ыфв фыв +7 9001112233 вфыв ыфв фыв \n\n"
"вфыв ыфв фыв 89001112233 вфыв ыфв фыв \n\n"
"вфыв ыфв фыв 8(900) 111-2233 вфыв ыфв фыв ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")