const regex = /(?:\+|\d)[\d\-\(\) ]{9,}\d/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\+|\\d)[\\d\\-\\(\\) ]{9,}\\d', 'g')
const str = `вфыв ыфв фыв 8 900 000-00-00 вфыв ыфв фыв
вфыв ыфв фыв +7 (900) 000 00-00 вфыв ыфв фыв
вфыв ыфв фыв +7 9001112233 вфыв ыфв фыв
вфыв ыфв фыв 89001112233 вфыв ыфв фыв
вфыв ыфв фыв 8(900) 111-2233 вфыв ыфв фыв `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}