#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([\w-.]+)@([\w-]+)(\.[\w.-]+)$"
Local $sString = "Created by David Carroll for Question on SoloLearn:" & @CRLF & _
" - https://www.sololearn.com/Discuss/1940608/?ref=app" & @CRLF & _
" - Also see: For List of TLD possibilities:" & @CRLF & _
" - https://regex101.com/r/9ugQHy/4" & @CRLF & _
"-----------------" & @CRLF & _
"Sample Data" & @CRLF & _
"-----------------" & @CRLF & _
"" & @CRLF & _
"example@example.com" & @CRLF & _
"example@example.net" & @CRLF & _
"example@example.com" & @CRLF & _
"d.c-123@some-domain.uk.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")