# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([\w-.]+)@([\w-]+)(\.[\w.-]+)$"
test_str = ("Created by David Carroll for Question on SoloLearn:\n"
" - https://www.sololearn.com/Discuss/1940608/?ref=app\n"
" - Also see: For List of TLD possibilities:\n"
" - https://regex101.com/r/9ugQHy/4\n"
"-----------------\n"
"Sample Data\n"
"-----------------\n\n"
"example@example.com\n"
"example@example.net\n"
"example@example.com\n"
"d.c-123@some-domain.uk.com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.